No daily backup report sent
Incident Report for Clean Mailbox
Resolved
Issue is resolved.
Posted Nov 30, 2023 - 00:00 CET
Monitoring
Since recently, daily backup reports were not being sent. The issue has been identified and fixed, we are monitoring the result for the next days.
Posted Nov 29, 2023 - 13:40 CET
This incident affected: Manager website.