Servers can't handle the load
Incident Report for Clean Mailbox
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 13:33 CET
Monitoring
Servers have been scaled, we'll monitor them for few hours.
Posted Nov 28, 2022 - 13:06 CET
Investigating
Due to recent increase of emails to handle (a lot of new customers from Protecmail), our filtering servers are not able to proceed all messages. All emails are correctly received & forwarded to your SMTP, but some of them might not be filtered. We are working on increasing our capacity.
Posted Nov 28, 2022 - 11:00 CET
This incident affected: Filtering servers.