Email delivery to Microsoft has resumed, and queued messages are being processed. We are monitoring the situation to ensure the service remains stable.
Posted Sep 04, 2026 - 14:53 CEST
Update
The incident can be tracked under reference "EX1467029" in Microsoft admin center.
Posted Sep 04, 2026 - 13:44 CEST
Identified
Microsoft’s SMTP servers are currently experiencing an outage, preventing our filtering gateway from delivering inbound emails. Messages are being queued securely and will be delivered automatically once Microsoft restores service.