DNS resolution issue

Incident Report for Clean Mailbox

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 16:40 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 10:55 CEST

Identified

The DNS resolver provided by the hosting provider is having technical issues, we've raised the issue with their support team.
Posted Sep 09, 2025 - 10:43 CEST

Investigating

One of our SMTP front server is failing DNS resolutions, leading to failures to deliver emails to remote destination where DNS resolution is required. We're investigating, it has been removed from the pool.
Posted Sep 09, 2025 - 10:38 CEST
This incident affected: SMTP front servers.