Incorrect message count in manager
Incident Report for Clean Mailbox
Resolved
This incident has been resolved.
Posted Dec 02, 2022 - 15:51 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2022 - 15:49 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 02, 2022 - 15:46 CET
Investigating
The number of filtered messages since the beginning of the month is currently incorrect on the manager. We're investigating.
It doesn't affect the delivery or the filtering of your emails. Only statistics.
Posted Dec 02, 2022 - 15:13 CET
This incident affected: Manager website.