Backend maintenance
Incident Report for Clean Mailbox
Resolved
Maintenance completed.
Posted Nov 21, 2022 - 17:28 CET
Investigating
Starting from 05:00pm CET today, you won't be able to add new domains through the GUI or API. We'll be doing a small maintenance to be able to on-board a lot of new customers (due to the end of service of Protecmail), and we need to not get any new domains during this maintenance. All emails will be filtered as usual for existing domains, no impact.
Posted Nov 21, 2022 - 16:54 CET
This incident affected: Manager website.