SSL/TLS restrictions on SMTP protocols - security improvement
Incident Report for Clean Mailbox
Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 13:56 CET
Monitoring
The new settings are applied to all servers. We'll continue to monitor them.
Posted Dec 07, 2021 - 12:43 CET
Update
The new settings are applied to 75% of our servers.
Posted Dec 07, 2021 - 12:05 CET
Update
The new settings are applied to 50% of our servers.
Posted Dec 07, 2021 - 11:42 CET
Identified
The new settings are applied to 25% of our servers.
Posted Dec 07, 2021 - 11:34 CET
Investigating
To improve security of SMTP transactions on our front-end servers, we are going to apply some SSL/TLS restrictions on SMTP transactions.

Upcoming changes (not exhaustive):
- Disable SSLv2, SSLv3, TLSv1 and TLSv1.1
- Restrict weak ciphers

We'll monitor the SMTP transactions during and after the maintenance to ensure there is no critical impact.
Only outdated clients might fail to send emails to our handled domains.
It might reduce the number of received spams, as spambots often use outdated stuff.
Posted Dec 07, 2021 - 11:30 CET
This incident affected: SMTP front servers.